-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Home
Apps
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


-
- Content .- Fans (1) .- Knowledge Base  . 

GUI Builder

   0.9.8  

KDE Development Tool

Score 66%
timothysaddresstimothysaddr ess
Simple Innovation
Home
-
Timothy Timothy Crosley 22

Simple Innovation
United States of America, Avon Park
Last visit 2 days ago
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--
GUI Builder
zoom


GUI Builder
zoom


Homepage:  Link
Downloads:  353
Submitted:  Mar 11 2013
Updated:  Apr 5 2013

Description:

GUI Builder is A drag and drop interface to create WebElement User Interface (WUI) templates that can be used as the foundation of a responsive wep app. It simplifies the process of designing applications, and encourages separation of the logic and view.

Part of the WebBot web development framework (www.webbot.ws) that enables building WebApps in a similar fashion to building QT/KDE apps.

To install:

1. Install PySide https://pypi.python.org/pypi/PySide

Note: PyQt4 works as well, if PySide is not available for you platform.


2. pip install webelements

3. pip install guibuilder

execute guiBuilder to run.

Note: easy_install can optionally be used instead of pip install




Changelog:

0.9.8
Ensure editing properties on complex templates doesn't result in slow-typing. Don't loose tree position on item delete. Remember which items are expanded so the state doesn't change when properties are edited or items deleted / added.
0.9.7
Add support for PyQt4 bindings in addition to PySide to enable GuiBuilder to run on more distributions.
0.9.6
This release includes changes to help reduce the likely hood that a user will lose unsaved changes, as well as live property validation and the removal of the ability to accidentally save invalid templates. Additionally a bug that caused intermittent loss of item selection when more then 1 root node was used has been fixed.
0.9.5
Bug fix release: fix save-as resetting filename, keep scroll position when content changes, auto-select even nested tabs to make editing content easier.
0.9.4
Integrate features from the latest version of WebBot - social API support and live validation elements (client-side and server-side)
0.9.3
Fixed issue displaying recently used files drop-down when using python3
0.9.2
Fixed further Python3 compatibility issues discovered by Mte90
0.9.1
Fixed Python3 compatibility issue discovered by Mte90




LicenseGPL
(WebBot Framework)
(Screencast: deploy GuiBuilder app in 15 minutes.)
Send to a friend
Subscribe
Other  Content  from timothysaddress
Report inappropriate content



-

 debian sid error

 
 by Mte90 on: Mar 14 2013
 
Score 50%

i have installed with pip and i get this
mte90@siduction:~$ guiBuilder
Traceback (most recent call last):
File "/usr/local/bin/guiBuilder", line 3, in <module>
from GuiBuilder import GuiBuilder
File "/usr/local/lib/python3.2/dist-packages/GuiBuilder/GuiBuilder.py", line 41, in <module>
import GuiBuilderConfig
ImportError: No module named GuiBuilderConfig


www.mte90.net
Reply to this

-
.

 Re: debian sid error

 
 by timothysaddress on: Mar 14 2013
 
Score 50%
timothysaddresstimothysaddr ess
Simple Innovation
Home
-
Timothy Timothy Crosley 22

Simple Innovation
United States of America, Avon Park
Last visit 2 days ago
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Hi Mte90,

Thanks for finding this issue, It was caused by an incompatibility with the latest python version - and I have made a patch to fix the issue:
a simple pip install guibuilder --upgrade and you should be good.

Thanks!

Timothy


Reply to this

-

 other problems

 
 by Mte90 on: Mar 14 2013
 
Score 50%

mte90@siduction:~$ guiBuilder
Traceback (most recent call last):
File "/usr/local/bin/webElementDocs", line 3, in <module>
from GuiBuilder import WebElementDocs
File "/usr/local/lib/python3.2/dist-packages/GuiBuilder/WebElementDocs.py", line 36, in <module>
import GuiBuilderConfig
ImportError: No module named GuiBuilderConfig

I get this error when i click on ? button.
I have seen that it's impossibile close the program by console, for do it this in pyqt the cose is:
signal.signal(signal.SIGINT, signal.SIG_DFL)
also i get this error when i use the combobox on the bottom
Traceback (most recent call last):
File "/usr/local/lib/python3.2/dist-packages/GuiBuilder/GuiBuilder.py", line 670, in updatePreview
self.updateTree()
File "/usr/local/lib/python3.2/dist-packages/GuiBuilder/GuiBuilder.py", line 450, in updateTree
for childElement in self.structure.childElements:
TypeError: 'NoneType' object is not iterable

There is a bugzilla XD?
also i can't drop anything :-/
the program is like qt designer but more simple, i like it!


www.mte90.net
Reply to this

-
.

 Re: other problems

 
 by timothysaddress on: Mar 14 2013
 
Score 50%
timothysaddresstimothysaddr ess
Simple Innovation
Home
-
Timothy Timothy Crosley 22

Simple Innovation
United States of America, Avon Park
Last visit 2 days ago
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Hi,

I have released another issue to fix the bugs you found. I'm currently relying on the github issues page: https://github.com/timothycrosley/GuiBuilder/issues
but have only started the process of making others aware of this tool, so as you can see no issues as of yet - your testing has already been very helpful.

Thanks for your comment on the design! currently I have not found a good way to enable drag and drop into the main view - currently you must drag and drop into the tree, and can only select items for editing from the main view.

Thanks!

Timothy


Reply to this

-
.

 No PiSide installed

 
 by Nebkheperureinpu on: Mar 16 2013
 
Score 50%

After:
Quote:
1. Install pyside https://pypi.python.org/pypi/PySide

2. pip install webelements

3. pip install guibuilder

A have that:
Quote:

guiBuilder
Traceback (most recent call last):
File "/usr/local/bin/guiBuilder", line 5, in <module>
pkg_resources.run_script('GuiBuilder==0.9.2', 'guiBuilder')
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 499, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1235, in run_script
execfile(script_filename, namespace, namespace)
File "/usr/local/lib/python2.7/dist-packages/GuiBuilder-0.9.2-py2.7.egg/EGG-INFO/scripts/guiBuilder", line 3, in <module>
from GuiBuilder import GuiBuilder
File "/usr/local/lib/python2.7/dist-packages/GuiBuilder-0.9.2-py2.7.egg/GuiBuilder/GuiBuilder.py", line 32, in <module>
from PySide.QtCore import *
ImportError: No module named PySide.QtCore

So, PiSide also must be installed before.


Reply to this

-
.

 Re: No PiSide installed

 
 by timothysaddress on: Mar 16 2013
 
Score 50%
timothysaddresstimothysaddr ess
Simple Innovation
Home
-
Timothy Timothy Crosley 22

Simple Innovation
United States of America, Avon Park
Last visit 2 days ago
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Hi Nebkheperureinpu,

Yes Pyside must be installed before guibuilder can start up correctly, if you let me know what distribution you use I can try to find more in-depth instructions for installing pyside for your specific set up. Once Pyside is installed guiBuilder should start up without issue.

Thanks!

Timothy


Reply to this

-
.

 Re: Re: No PiSide installed

 
 by Nebkheperureinpu on: Mar 17 2013
 
Score 50%

I have Kubuntu 12.04 LTS on my PC. After installing PySide guiBuilder work's fine. Thanks! ;)


Reply to this

Add commentBack






-
openDesktop.org Facebook App




 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add Content
Public API
About openDesktop.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2007-2014 openDesktop.org Team  
All rights reserved. openDesktop.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
openDesktop is a trademark of the openDesktop.org Team